aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Prepare 0.8.1 releaseHEADmasterRonan Amicel2012-10-262-1/+9
|
* Upgrade default pip version to 1.2.1Ronan Amicel2012-10-261-3/+6
|
* Really fix pip version parsing issueRonan Amicel2012-10-261-1/+1
|
* Prepare 0.8.0 releaseRonan Amicel2012-10-262-1/+9
|
* Fix locales support on Debian [#42]Ronan Amicel2012-10-264-21/+57
|
* Add extra options to create_user (thanks to Gaƫl Pasgrimaud) [#40]Ronan Amicel2012-10-251-2/+9
|
* No need to sudo to run getent [#40]Ronan Amicel2012-10-251-1/+1
|
* Merge pull request #41 from liZe/patch-1Ronan Amicel2012-10-251-4/+8
|\ | | | | Use the version number from setup.py in the documentation
| * Deduplicate the version for the docGuillaume Ayoub2012-10-191-4/+8
| | | | | | This regexp takes the version from setup.py and puts the right number in the breadcrumb.
* | Fix potential issue with pip version parsingRonan Amicel2012-10-231-1/+1
|/ | | | | In some cases, warnings could be emitted on stderr, which would break our version parsing.
* Prepare 0.7.0 releaseRonan Amicel2012-10-132-1/+7
|
* Add test task for directory creationRonan Amicel2012-10-131-0/+33
|
* Only change owner or permissions when neededRonan Amicel2012-10-131-5/+13
|
* Add functions to get a file's owner, group and modeRonan Amicel2012-10-131-0/+30
|
* require.directory should set ownership and mode on existing directories.Troy J. Farrell2012-10-131-4/+4
|
* Prepare 0.6.0 releaseRonan Amicel2012-10-132-1/+7
|
* Add test tasks for Node.js modulesRonan Amicel2012-10-131-0/+100
|
* Add require.nodejs moduleRonan Amicel2012-10-137-2/+126
|
* Factor out install_dependencies() in Node.js moduleRonan Amicel2012-10-131-13/+27
|
* Rename functions in Node.js moduleRonan Amicel2012-10-131-11/+11
|
* Fix npm lock permission issueRonan Amicel2012-10-131-3/+3
|
* Refactor to use the same parameter name for local operationsRonan Amicel2012-10-131-22/+22
|
* CleanupRonan Amicel2012-10-131-9/+8
|
* Python 2.5 compatibilityRonan Amicel2012-10-131-12/+12
|
* Update default Node.js version to 0.8.11Ronan Amicel2012-10-131-1/+4
|
* Update Node.js documentationRonan Amicel2012-10-133-13/+60
|
* Import nodejs module in fabtools module namespaceRonan Amicel2012-10-131-0/+1
|
* debug install node task and update package taskFrank Rousseau2012-10-131-10/+11
|
* make file pep8 compliantFrank Rousseau2012-10-131-2/+5
|
* add nodejs module to manage Node JS environmentsFrank Rousseau2012-10-131-0/+73
|
* add vim swap files to .gitignoreFrank Rousseau2012-10-131-0/+1
|
* Tweak documentationRonan Amicel2012-10-133-9/+9
|
* Merge pull request #38 from laurentb/masterRonan Amicel2012-10-121-1/+1
|\ | | | | Fabric 1.4 or later is now required
| * Fabric 1.4 or later is now requiredLaurent Bachelier2012-10-121-1/+1
|/ | | | Because of (at least) fabric.utils.error.
* Fix #4 (for real this time?)Ronan Amicel2012-09-252-1/+13
|
* Documentation fixesRonan Amicel2012-09-216-5/+11
|
* Fix manifestRonan Amicel2012-09-211-1/+2
|
* Switch project URL to Read the DocsRonan Amicel2012-09-211-1/+1
|
* Fix setup.pyRonan Amicel2012-09-211-1/+1
|
* Bump version to 0.5Ronan Amicel2012-09-211-1/+1
|
* Update docs for release of version 0.5Ronan Amicel2012-09-213-9/+10
|
* Improve documentationRonan Amicel2012-09-2170-232/+2026
|
* Remove unused parameterRonan Amicel2012-09-211-1/+1
|
* Merge pull request #28 from cyberj/masterRonan Amicel2012-09-171-1/+2
|\ | | | | Tests fail if vagrant isn't installed
| * Fix tests when vagrant isn't installedCharpentier Johan2012-09-171-1/+2
|/
* Improvements to the network moduleRonan Amicel2012-09-142-2/+76
|
* Fix vagrant test casesRonan Amicel2012-09-122-27/+10
|
* Fix OpenVZ integration testRonan Amicel2012-09-121-2/+6
|
* Fix require MySQL server on Ubuntu 12.04 LTSRonan Amicel2012-09-111-3/+8
|
* Refactor watch context managerRonan Amicel2012-09-118-51/+89
|